Install#

Getting started#

What do you want to do?

Choose an installation method#

Developers may choose to install Plone from either the official container images or source.

The Plone 6 container images are compliant with the Open Container Initiative (OCI). They should work with any OCI-compliant container engine for developing, managing, and running Plone 6 images. Two popular options include podman and Docker. The Plone 6 images have all the system requirements, pre-requisites, and Plone 6 already installed, except those requirements needed for running the container engine itself. This option is the quickest method to install and develop for Plone 6 and its packages.

There may be some cases where using a Plone 6 image is not practical or desired. You might want to use an SQL database that is not PostgreSQL, or you might use a deployment workflow that has specific requirements. For these situations, Plone 6 may be installed manually. This method takes longer. It might be a challenge if you bump up against system requirements, or need to resolve conflicts between required packages.

Todo

Perhaps merge the subsequent section into this section?

Caveat that Plone is a large project and source installs are non-trivial#

System Requirements#

System requirements depend upon your choice of installation method: